fbpx

Downloads

Server hiQoo

hiQoo per iPhone

Requisiti: iOS 8.1 o succesivi. Compatibile con iPhone, iPad, ed iPod touch.

hiQoo per Mac OS X

Requisiti: MacOS Ver. Minima OS X 10.11 (64 bit)

hiQoo per Windows OS

Requisiti: Windows XP sp2 o successivi.